Puff & puff....nothing happens



  • Worked fine right out of the box, but now....no smoke, *wasting cannabis., i don't know what to do. The airpath filter is clear. Help.



  • Sent my Legacy back to the Airvape folks..It was found to be defective..received a new one...checked the filters...poked the holes in the rubber gasket...it's new so no gunk, etc. etc.but no vapor. I read all the great reviews of the Legacy, and i wonder why I seem to be the only one experiencing this



  • @Gail Thanks for sharing your feedback. We’re sorry your experience didn’t match your expectations. It was an uncommon instance and we’ll do better in the future. Looks like a representative has reached out to you regarding this matter. You are in good hands and if anything else comes up, feel free to reach us at cs@airvapeusa.com. We will always be happy to help, enjoy the rest of the day!



  • @cusamo17 Been sitting on a shelf now for months. Not working. Very frustrated. III trPlease help me. The Legac has been siting on a shelf for months. It does not work. I wish, truly, that I had never bought this.



  • Still not working



  • Hello @anxioushacker, oh no, definitely understand that having the same issue "twice" can be really troublesome. Not to worry, we heard you and it looks a representative has reached out to you regarding the issue that you are getting with your device. Don't forget to provide them a video of the said matter as well as to register your device for the warranty to ensure warranty coverage. Let me know if there is any else that we could do to help a fellow airvaper. You can also reach us at cs@airvapeusa.com. Enjoy the rest of the day!



  • Having the same issue with my Legacy. Worked well for the first couple months then started getting "Sensor error" which was solved a few times by cleaning... then the issue/error started to get more frequent and now even after a very through clean of the entire unit as per instructions above the error still shows and now I have a dead fancy vape 😞

    I'm hoping this was a batch issue with the Legacy because I had a couple AirVapeX and Go and never experienced such issues



  • When you are looking inside your Legacy, the bowl is on the right bottom. Above the bowl to the left, there is a small screen, remove it, and get all the gunk out of that hole, and wipe/soak the screen with alcohol. I had this same problem, and was heartbroken. Cleaned that out, and the magic was back!



  • @sajan26586 We are so sorry for what happened and we will do our best to help you with this matter. May we please have your email address so our customer service representative can reach out to you?



  • My Legacy is fucked up pretty bad from the day I took it out of the box. First it was overheating to the extent of burning my hand and now It says sensor error.

    Seems the device is pretty messed up.



  • @Gail Thank you for providing your email address. We have forwarded this to our customer service team and they will reach out to you shortly.



  • @ekomS Thank you. my email is--> discogail@gmail.com



  • Hi @Gail We would love to get this resolved for you. Can you please give me your email address so our customer service can reach out to you or if you are not comfortable in providing your email address, you may send us an email at cs@airvapausa.com



  • @cusamo17 Still doesn't work. no vapor..no smoke. Cleaned filters (2), poked the little holes in the rubber filter...the glass tube refuses to come out. It's now stuck so tight in it's compartment.tried removing the battery...



  • @Gail We are a four vape family. Kristy uses hers for tobacco. We both have the X and the XS Go. That's how much we love Airvape. I believe the Legacy to be designed more for those who use concentrates even though you can put flower in it. I hear it rocks the rocks...and wax, and shatter. I'm more of a real herb person, so the X and XS Go are the best. Try the XS Go for a back-up. I do a modification to both the X and XS Go to make them draw easier, too. Let me know if you're interested it's easy. Enjoy!



  • @cusamo17 Thank you very much.. I will do that. My prior vaporizer was (and still is) the Airvape X.



  • @Gail what do you mean by nothing? Is the chamber getting hot? Is there airflow? The airpath with that device can be a bit tricky. It is dependant on two factors; one is how clear the filters are and there are two. One is the little gold one next to the bowl which is easy to pop out and clean. The other isn't so easy to spot and thus not so easy to keep clean. It is the black hard circle with tiny holes in it mounted to the case lid and surrounded by the rubber gasket. If those tiny holes are clogged, new air won't enter the bowl thus cutting off the air flow into the bowl. Instead, it leaks through the gasket/lid connection. First of all, clean the black circle thingy as best as you can. The vid shows a quick brushing, but that won't do it. I had to poke each one out with a fine wire, then use a paper towel and drag it behind the circle thingy until no more gunk was visible and I could see through the holes. Clean the gold screen and dig underneath where it sits. Gunk builds up there, too and it is NOT easy to get out. Then, there is the place where the glass tube sits there. That needs to be checked, too. After that, there aren't any more places that usually get clogged. Just remember you will have to do this at least once a week or more as I had to do. Another trick is to hold the lid closed tight while drawing. It makes a better seal. I also found if the product isn't touching the metal bowl as much, it won't vape meaning they are counting on the convection effect to vape the stuff. I found it to be more hit than miss, but still many misses. If you try to compensate by turning it up, it could over burn, so be careful there, too. What vaporizer did you use prior?



  • It heats up fine. Then nothing. Strange, because it was great the first time i used it.



  • Oh, ya. The Legacy...it's a bit much.
    What exactly is it doing?



  • Oh, Sorry. The Airvape Legacy. Thanks.


Log in to reply